Significon-Twitter-256.png

Headline: Mountain Lion Drops Support of Older Macs

Headline: Mountain Lion Drops Support of Older Macs

Mountain Lion machine requirements have been known for some time. However with the recent Golden master build seeded apple has reported they have dropped support from some early 64-bit Macs that do support Lion. There is an on going disccution over at Ars Technica In order to run Mountain Lion Your Mac must be one of the following models:

- iMac (Mid 2007 or newer) - MacBook (Late 2008 Aluminum, or Early 2009 or newer) - MacBook Pro (Mid/Late 2007 or newer) - MacBook Air (Late 2008 or newer) - Mac mini (Early 2009 or newer) - Mac Pro (Early 2008 or newer) - Xserve (Early 2009)



Headlines: Google aquired Sparrow

Headlines: Google aquired Sparrow

Headline: Dropbox set to double storage

Headline: Dropbox set to double storage